The RStudio IDE is an Integrated Development Environment in R that comes in three versions
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for teams that share large compute
resources, large data, and uniform
environments for collaboration

learn more at www.rstudio.com Alocal version of the IDE for larger compute resources
- - =, for your desktop and remote access
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Download all at www.rstudio.com. Each provides the same useful interface:

Documents and Apps Write Code R Support RStudio Pro Features

J2)e)e!
J2)e)e!
J2)e)e!

e Shirgg, R Dl Navigate Openinnew Save Findand Compileas Run '“f‘tffr,t da;a file  History ogpatst D[!Sdplaﬁ/ -RPres Share Project Active shared  Start new R Session
Z . ; 4 tabs window replace  notebook  selected with wizar commands to SllglESIMomE with Collaborators... collaborators .-in current project
. — knitr, Sweave, LaTeX, Rd files : ; code . ne n/add to source File > New File > ;
and more in Source Pane : i - i - R Presentation : P— c.»'@ ] Close R Session
: " ; - g T || garrett | ** Sessions~ . . .
- " - < - ~ — — ; in project
Chec'k Render Choose Choose Insert File < Edit Cod.e’. View - Plots Seé;ion Build.- Debug Tools Help~" : m garrett [+ Sessions~ | @ =y IDEcheatsheet » | R 3.2.2 weprerereeeeees
spelh.ng OUtpUt OUtpUt OUtpL_"t code g). d’...' = | (A God 1% file/function - - - Ad.dfﬁ.s.v :': & IDEcheatsheet ~  R3.2.2 ~ G New Project... v Ryversion 3.2.2 Select'
% format location chunk : pi— - —ic | , : , R Version
5 . QJ RMarkdoWn Rmdr % @jappRx @] §cr|pt.R x | - Environment : History Build Git Presentation » == : &2 Open Project... : R version 3.1.3
e RMarkdown.qu * | Rlapphx @] Scrlpt Rx - =0 L T Q 2| E — Rl'J:n___.geb (#Source ~| = | S H.! 7T:rblmport Dataset {._.' Listw, | (&) Close Project R version 3.0.3
b | A ue Qg knieHMLE G TRONR R e 1 I# Good start.. | """"""""""""" : % Global En\./;l:t;r.\-rr.;e.n.t':"-, i "o | 1 Share Project... R version 2.15.3
1 el e T R T e ) L i : .
2 IR R : 2 i Cursors of Re-run - Source with or Shovv file | Load : Save Delete all Search inside : Decheatsheer 4D .
3 Jumpto Jump  Run~  Publish  Showfile i “shared users previous code withoutEcho  outline workspace | workspace saved objects  environment - . :::::::”e"“a's : 4 Project System
4 R H : : : “
revious tonext selected toserver outline . . ‘ o iny- i 5 . .
> Ehunk chunk  lines 500 e Multiple cursors/column selection Choose environment to display from D|splay obJ‘ects shiny e*:"""'e_s ; - File > New Project
g 6 "P0030001" with Alt + mouse drag. list of parent environments as list or grid Clear Project List ¢ RStudio saves the call history
. 7 "P0030002" Project Options... : 08, . ’
g Access markdown guide at 3 "PO030003" Code diagnostics that appear in the margin. ‘D)a‘ta. — B : workspace, and working
10 Help>Markdown Quick Reference 9 "pag3eges .Hoverover diagnostic symbols for details. , :L”S obs. of 5 variables e Name of dwgctory associated with a
1 10 . oues L e project. It reloads each when
12 Jumpto Setknitr Runthisand Run this g e Syntax highlighting based | . = .. you re-open a project.
13 i o ile' i :
B chunk  chunk  allprevious code chunk 013" get_digit < function() on your file's extension foo function GO 8
options  code chunks " £13 Cnum® %% (10 A ) . .
12 L : o A Tab completion to finish . . . . T RStudio opens plots in a dedicated Plots pane
1 i orbssure, echostaLssy T " 114 %/% (10 A (n - 1)) _..--function names, file paths, Displays saved objects by View in data View function FEy i ([Pl R e —
e u = f . . .
e plot(p':essure) T arguments, and more. type with short description viewer source code & | B zoom | Boon: | QL] e, S ruish | @
- 16 : R L
19- : e P e T
2 e N 1; fgﬂw ..‘{s.r‘l;.ppet}- _______________________ Multi-language code e T — =0 Navigate O_pen in “Export " Delete " Delete
o f {.GlobalEnv} Smppets tO quCkly use @\ New Folder % | Upload 0_, Delete | Rename a More ~ ‘U recent plOtS WlndOW pIOt plOt a“ plOtS
: : : 19 : 00 ket common blocks of code. £ Home  IDEcheatjheet : : Cony... B ] '
RStudio recognizes that files named app.R, 20 | force {base} P anabe g g Move. GUI Package manager lists every installed package
server.R, ui.R, and global.R belong to a shiny app 21 Jump to function in file Change file type § : § ; ; bxport.. Files | Plots | Packages | Help | Viewer =5
©) RMarkdown Rmd % ©1appR % 0 SeritR ¢ =0 22 i | Create i Upload Delete Rename | setAsWorking Directory. Change i | @ toye | Wrckes :
8 2l b ___,_4,.._..._.......-_‘_‘_‘.'_,’..'f_",".éfff’ - Jj B c“ | (sz Lern;DF _— =2 folder ; file file  file o To Working Pirectory] directory Install Update  Create reproducible package
5 U VN 5 bl hto =M o =0 : Packages Packages library foryour project
3 un oose ublish to anage e — Path to dlSplayed directory ) scales Scale Functions for Visualization 0.3.0
" app locationto shinyapps.io publish > foo(1) el Workin Maximize ;Y @ shiny Web Application Framework for R 0122
5 V|eW a pp or server accounts [1] 2 - . g PR ’ & - () shinydashboard Create Dashboards with 'Shiny' “0.5.1
- > foo <- function(x) x + 1 Dlrectory minimize panes J hello.R 4508 Dec 24, 2015, 8:55 AM : .
iG] (Top Level) = R Script * foo(2) i . . s . . -
> | foo(2) _..-Press 4> to see Drag pane - A File browser keyed to your working directory. Click to load package with Package Delete
> | foo(1) =" command history boundaries Click on file or directory name to open. library(). Unclick to detach version  from
ackage with detac installe ibrar
package with detach talled library
Debug Mode Version Control with Git or SVN , o :
RStudio opens documentation in a dedicated Help pane
Launch debugger ~ Open traceback to examine =§=  TurnonatTools > Project Options > Git/SVN ey . e
. . . . . . . — S -4 L — [n - =
Open with debug(), browse(), or a breakpoint. RStudio will open the mode from origin  the functions that R called ﬁ Stage Showfile Commit  Push/Pull  view R Antmeic Operstrs - £ e, :
debugger mode when it encounters a breakpoint while executing code.  oferror ... before the error occurred files: diff sta - ﬂles toremote  Hist : 3 )
T E ' es‘.n. : : e Istory Home page of Search within Search for
Click next to™ et x| Juman | it | Qoiramrss | =D oo [y e o T—— ~/IDEcheatsheet’]'~.,‘ :.: —— u Added Envg;:me/m Co::::ry G:f L a ,,,,,,,,,, mas[erﬂa helpful links help file help file
7 # In da::';: hethf‘(tuo:o:‘; ve number is a palindrome ::\::veme«v- B g RS L - - : . . .
line number to'f. ¢ ""’é\;‘fsf oo, ) 13 T — > fooO | o aelg'tfe‘dd e o Heowith-changesk | © Revert- : Viewer Pane displays HTML content, such as Shiny apps,
10-  for (x in 1:((digits %/% 2 digits 5 ) L. .. 3 = . : A . . A :
add/removea | st - Error in get_digit(num, X>.: * Show Traceback @ Modifie ignore... : RMarkdown reports, and interactive visualizations
breakpoint. | i me T a Lo v S @ Renamed | Openshellto | current -5
- BT — Untracked| type commands branch 2 e e publsh + | @
O I i RS :
o 18 : :
. . ° 19 # Find the largest palindrome that is the product of two 34{ g 'T":“;':‘“r';m! TS o i r;:’w Infecra : . . . .
{—ii r|1 %hsl;’] ggvzesd e fanctont> T p e CoRSHIE S IDECHEatShaat) e Package Writing igopp Shiny F ;Ubégsth;Csoh n| ?e/i 'E) ps.io,  Refresh
Whel'e “m;uma‘auw));/%(w (ns» ) . Files s Help  Viewer “E NEXt P} “__ } Cont!nue . Stop
execution Nas [l « g e . : 5 : } File > New Project > Erermen Wy Vlew(<data>) opens spreadsheet like view of data set
paused deb;gta; g/zz;::m(ss::rt\:\a\igissentmls Z/palmdrm R#12: digit2 ‘ ‘ ) | Build & Reload Check gk More~| Fllter :
Bmm[z‘] NeW DlreCtory = R PaCkage “ Z::n:ll‘d Rebuild o "._ Sepal.Length Sepal.Width Petal.Length : Petal.Width ESpecies
g : : 5 : . Turn project into package, TestPackege  HF7 i [an p LAl
Run commands in Examine variables Select function Step through  Step into and Resume Quit debug El_nablle:%xygentd8C$.ment>a1E3|o[1l(\;v_||§h | crcratre o 1)} 51 35 L 0.2 setosa
a o 5 5 3 N . Build Source Package . : :
environment where  in executing in traceback to codeoneline outof functions execution mode 0015 > Froject Options > build Tools B iy Pk N : o rch
execution has paused  environment debug atatime to run Roxygen guide at bocumens 00 3 Filter rows by value Sort by Searc
. X Configure auld Tools.. 4 orvaluerange values forvalue
Help > Roxygen Quick Reference

RStudio®is a trademark of RStudio, Inc. » CC BY RStudio « info@rstudio.com « 844-448-1212 « rstudio.com  More cheat sheets at http://www.rstudio.com/resources/cheatsheets/ Learn more at support.rstudio.com « RStudio IDE 0.99.832 « Updated: 01/16


https://creativecommons.org/licenses/by/4.0/
mailto:info@rstudio.com
http://rstudio.com
http://www.rstudio.com/resources/cheatsheets/

1 LAYOUT
Move focus to Source Editor
Move focus to Console

Move focus to Help
Show History
Show Files

Show Plots

Show Packages
Show Environment
Show Git/SVN
Show Build

2 RUN CODE

Search command history
Navigate command history
Move cursor to start of line
Move cursor to end of line
Change working directory

Interrupt current command Esc

Clear console

Quit Session (desktop only)

Restart R Session

Run current line/selection
Run current (retain cursor)
Run from current to end
Run the current function

Source a file

Source the current file

Source with echo

3 NAVIGATE CODE
Goto File/Function
Fold Selected
Unfold Selected
Fold All

Unfold All

Goto line

Jump to

Switch to tab
Previous tab

Next tab

First tab

Last tab

Navigate back
Navigate forward
Jump to Brace
Select within Braces
Use Selection for Find
Find in Files

Find Next

Find Previous
Jump to Word
Jump to Start/End

Windows/Linux Mac
Ctrl+1 Ctrl+1
Ctrl+2 Ctrl+2
Ctrl+3 Ctrl+3
Ctrl+4 Ctrl+4
Ctrl+5 Ctrl+5
Ctrl+6 Ctrl+6
Ctrl+7 Ctrl+7
Ctrl+8 Ctrl+8
Ctrl+9 Ctrl+9
Ctrl+0 Ctrl+0
Windows/Linux Mac
Ctri+a Cmd+4
A 4 IR 4
Home Cmd+€
End Cmd+=»
Ctrl+Shift+H Ctrl+Shift+H
Esc
Ctrl+L Ctrl+L
Ctrl+Q Cmd+Q
Ctrl+Shift+F10  Cmd+Shift+F10
Ctrl+Enter Cmd+Enter
Alt+Enter Option+Enter
Ctrl+Alt+E Cmd+Option+E
Ctrl+Alt+F Cmd+Option+F
Ctrl+Shift+O Cmd+Shift+O
Ctrl+Shift+S Cmd+Shift+S
Ctrl+Shift+Enter  Cmd+Shift+Enter
Windows /Linux Mac
Ctrl+. Ctrl+.
Alt+L Cmd+Option+L
Shift+Alt+L Cmd+Shift+Option+L
Alt+O Cmd+Option+0
Shift+Alt+O Cmd+Shift+Option+0
Shift+Alt+G Cmd+Shift+Option+G
Shift+Alt+J Cmd+Shift+Option+J
Ctrl+Shift+. Ctrl+Shift+.
Ctrl+F11 Ctrl+F11
Ctrl+F12 Ctrl+F12

Ctrl+Shift+F11
Ctrl+Shift+F12
Ctrl+F9

Ctrl+F10

Ctrl+P
Ctrl+Shift+Alt+E
Ctrl+F3

Ctrl+Shift+F

Win: F3, Linux; Ctrl+G

W: Shift+F3, L: Ctrl+Shift

Ctrl+ €&/
Ctri+av /¥

Ctrl+Shift+F11
Ctrl+Shift+F12
Cmd+F9
Cmd+F10
Ctrl+P
Ctrl+Shift+Alt+E
Cmd+E
Cmd+Shift+F
Cmd+G
Cmd+Shift+G
Option+ €/=
Cmd+4d /¥

4 WRITE CODE
Attempt completion
Navigate candidates
Accept candidate
Dismiss candidates
Undo

Redo

Cut

Copy

Paste

Select All

Delete Line

Select

Select Word

Select to Line Start
Select to Line End
Select Page Up/Down
Select to Start/End
Delete Word Left
Delete Word Right
Delete to Line End
Delete to Line Start
Indent

Outdent

Yank line up to cursor
Yank line after cursor
Insert yanked text
Insert <-

Insert %>%

Show help for function
Show source code
New document

New document (Chrome)

Open document
Save document
Close document

Close document (Chrome)

Close all documents
Extract function
Extract variable
Reindent lines
(Un)Comment lines
Reflow Comment
Reformat Selection
Select within braces
Show Diagnostics
Transpose Letters
Move Lines Up/Down
Copy Lines Up/Down
Add New Cursor Above
Add New Cursor Below
Move Active Cursor Up

Move Active Cursor Down

Find and Replace
Use Selection for Find
Replace and Find

Windows /Linux
Tab or Ctrl+Space
K 2

Enter, Tab, or =
Esc

Ctrl+Z
Ctrl+Shift+Z
Ctrl+X

Ctrl+C

Ctrl+V

Ctrl+A

Ctrl+D
Shift+[Arrow]
Ctrl+Shift+ €/=»
Alt+Shift+€
Alt+Shift+=p
Shift+PageUp/Down
Shift+Alt+4s /¥
Ctrl+Backspace

Tab (at start of line)
Shift+Tab
Ctrl+U

Ctrl+K

Ctrl+y

Alt+-
Ctrl+Shift+M

F1

F2

Ctrl+Shift+N
Ctrl+Alt+Shift+N
Ctrl+O

Ctrl+S

Ctrli+W
Ctrl+Alt+W
Ctrl+Shift+w
Ctrl+Alt+X
Ctrl+Alt+V

Ctrl+|
Ctrl+Shift+C
Ctrl+Shift+/
Ctrl+Shift+A
Ctrl+Shift+E
Ctrl+Shift+Alt+P

Alt+as /b
Shift+Alt+4v /b
Ctrl+Alt+Up
Ctrl+Alt+Down
Ctrl+Alt+Shift+Up
Ctrl+Alt+Shift+Down
Ctrl+F

Ctrl+F3

Ctrl+Shift+J

Mac

Tab or Cmd+Space
X JA 2

Enter, Tab, or =
Esc

Cmd+Z
Cmd+Shift+Z
Cmd+X

Cmd+C

Cmd+V

Cmd+A

Cmd+D
Shift+[Arrow]
Option+Shift+ €=/=»
Cmd+Shift+€
Cmd+Shift+=p
Shift+PageUp/Down
Cmd+Shift+4d /b
Ctrl+Opt+Backspace
Option+Delete
Ctrl+K
Option+Backspace
Tab (at start of line)
Shift+Tab

Ctrl+U

Ctrl+K

Ctrl+y

Option+-
Cmd+Shift+M

F1

F2

Cmd+Shift+N
Cmd+Shift+Alt+N
Cmd+0O

Cmd+S

Cmd+W
Cmd+Option+W
Cmd+Shift+W
Cmd+Option+X
Cmd+Option+V
Cmd+l
Cmd+Shift+C
Cmd+Shift+/
Cmd+Shift+A
Ctrl+Shift+E
Cmd+Shift+Alt+P
Ctrl+T
Option+4> /¥
Cmd+Option+4y /¥
Ctrl+Alt+Up
Ctrl+Alt+Down
Ctrl+Alt+Shift+Up
Ctrl+Alt+Shift+Down
Cmd+F

Cmd+E
Cmd+Shift+J
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5 DEBUG CODE

Windows/Linux Mac

Toggle Breakpoint Shift+F9 Shift+F9
Execute Next Line F10 F10

Step Into Function Shift+F4 Shift+F4
Finish Function/Loop Shift+F6 Shift+F6
Continue Shift+F5 Shift+F5

Stop Debugging Shift+F8 Shift+F8

6 VERSION CONTROL Windows/Linux Mac

Show diff Ctrl+Alt+D Ctrl+Option+D
Commit changes Ctrl+Alt+M Ctrl+Option+M
Scroll diff view Ctri+av /¥ Ctri+av /¥
Stage/Unstage (Git) Spacebar Spacebar
Stage/Unstage and move to next  Enter Enter

7 MAKE PACKAGES Windows/Linux Mac

Build and Reload Ctrl+Shift+B Cmd+Shift+B
Load All (devtools) Ctrl+Shift+L Cmd+Shift+L
Test Package (Desktop) Ctrl+Shift+T Cmd+Shift+T
Test Package (Web) Ctrl+Alt+F7 Cmd+Alt+F7

Check Package Ctrl+Shift+& Cmd+Shift+E
Document Package Ctrl+Shift+D Cmd+Shift+D

8 DOCUMENTS AND APPS Windows/Linux Mac

Preview HTML (Markdown, etc.) Ctrl+Shift+K Cmd+Shift+K
Knit Document (knitr) Ctrl+Shift+K Cmd+Shift+K
Compile Notebook Ctrl+Shift+K Cmd+Shift+K
Compile PDF (Tex and Sweave) Ctrl+Shift+K Cmd+Shift+K
Insert chunk (Sweave and Knitr) Ctrl+Alt+ Cmd+Option+|
Insert code section Ctrl+Shift+R Cmd+Shift+R
Re-run previous region Ctrl+Shift+P Cmd+Shift+P
Run current document Ctrl+Alt+R Cmd+Option+R
Run from start to current line  Ctrl+Alt+B Cmd+Option+B
Run the current code section Ctrl+Alt+T Cmd+Option+T
Run previous Sweave/Rmd code Ctrl+Alt+P Cmd+Option+P
Run the current chunk Ctrl+Alt+C Cmd+Option+C
Run the next chunk Ctrl+Alt+N Cmd+Option+N
Sync Editor & PDF Preview Ctrl+F8 Cmd+F8
Previous plot Ctrl+Alt+F11 Cmd+Option+F11
Next plot Ctrl+Alt+F12  Cmd+Option+F12
Show Keyboard Shortcuts Alt+Shift+K Option+Shift+K

Why RStudio Server Pro?

Do everything you would do with the open source server with a
commercial license, support, and more.

« edit the same project at the same time as others

« switch easily from one version of R to a different version

« open and run multiple R sessions simultaneously

« see what you and others are doing on your server

« tune your resources to improve performance

o integrate with your authentication, authorization, and audit practices

Download a free 45 day evaluation at
www.rstudio.com/products/rstudio-server-pro/
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